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Preface 

Epi Info™ is a public domain suite of interoperable software tools designed for the 

global community of public health practitioners and researchers. Perform data 

analysis with epidemiologic statistics, maps, and graphs. Build data entry forms, 

construct a database, and customize statistics applications. Physicians, 

Epidemiologists, and public health officials without a technical background can 

easily work with critical data using Epi Info™ tools. 

Use this guide alone or as a supplement to other Epi Info™ guides.  On the next 

page, view the complete collection of helpful guides available for Epi Info™ tools. 

The diagram shows how this guide highlighted with the bookmark icon  fits into 

the big picture of the Epi Info™ suite.  Additional guides may offer prerequisite 

information for the tool you’re working with.  For example, if you’re working with 

Epi Info™ Web Survey (EIWS), then you are creating a custom data entry form and 

publishing it to an EIWS system deployed in your environment. Business logic is 

added to the developed form in Form Designer. Therefore, you may need to begin by 

consulting the Epi Info™ Guide to Form Designer as indicated by the prerequisite 

documentation icon ( ).  Additionally, you may find helpful other guides that are 

indicated by the optional documentation icon ( ). 
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The image below shows the interrelationships among the guides in the series.  This 

guide is Getting Started with Epi Info™ – Guide to Web Survey.
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Web Survey: Surveys Through the Internet 

Section Topics  

Web Survey System Introduction Publish Forms to the Web 

Designing Forms for the Web Invite Respondents 

Supported Field Types, Commands and Functions Importing Survey Data 

Initial Setup Survey Manager Users Guide 

Introduction 

 

The Epi Info™ Web Survey System allows the survey designer to collect information 

from respondents over the Internet. Web Survey gives survey designers access to a 

wide variety and number of respondents. Publish survey forms to any pre-

configured web server hosted by your institution or provider. When published, Epi 

Info™ creates a survey specific website address. The survey designer can distribute 

survey links over email, by posting links on a web page, or using other methods. 

Respondents access the web survey and submit their responses through a web 

browser or mobile device. After the respondent answers the survey, the survey 

designer downloads the response into the original Epi Info™ 7 project for analysis. 

https://cdc.sharepoint.com/:w:/r/teams/CSELS-DHIS-ISBEpiInfoTeam/Shared%20Documents/Epi%20Info%20User%20Guide/Epi%20Info%20User%20Guide/05.%20Web%20Survey/Publication%20Copy%20Survey%20Manager/Survey%20Manager%20Drafts/Current%20Survey%20Manager%20Users%20Guide%20Draft%202.docx?d=w9d40acf6ef9e4c8099823cb6bbfa52fa&csf=1&web=1&e=DOJWbn
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                                                        Web Survey System 

 

Epi Info™ Web Survey System Deployment 

 

The Epi Info™ Web Survey System is a companion to the Epi Info™ 7 suite of tools, 

and a separate package apart from Epi Info™ 7. The Web Survey System requires a 

server running Microsoft Internet Information Services (IIS) and a SQL Server 

database. The database securely allows users to publish surveys and collect data 

submitted by respondents. Without access to web and database servers hosting the 

Epi Info™ Web Survey System, users cannot publish surveys and collect data over 

the Internet using Epi Info™ 7.  

Additional information about the Epi Info™ Web Survey System is located on the 

Epi Info™ Web Survey page. This site contains setup instructions and links to 

download the free deployment package kit.  

This user guide outlines the steps required to design and publish a form using the 

Epi Info™ 7 Form Designer tool, and import data submitted by survey respondents 

with Epi Info™ 7 Enter Data. The technical aspects of configuring web and 

database servers are beyond the scope of this guide.  

https://www.cdc.gov/epiinfo/cloud.html
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Request keys and settings for the Web Survey System from your system 

administrator or managed services group responsible for supporting Epi Info™ Web 

Survey System. 

Designing Forms for the Web 

 

The Epi Info™ Web Survey System allows for publishing short, single form projects 

(without grids) to the web for online data entry. Certain features and behavioral 

differences exist between the web survey format and Epi Info™ 7 operation. Plan 

for these differences before designing a survey (not all field types or check code 

commands are supported). Also, required fields and drop-down lists may behave 

differently on web browsers than within Epi Info™ 7 Enter Data.  

Start by setting the computer resolution to 1366 x 768 or 1024 x 768. These 

resolutions are common for desktop survey respondents. These settings minimize 

discrepancies between how the survey appears to both designer and respondent. 

Adjustments for desktop resolutions are not required for survey respondents using 

browsers on smart phones and tablets. The Epi Info™ Web Survey System adjusts 

the display when a survey respondent uses a mobile device. Surveys for these 

smaller, screen-sized devices appear with a stacked question arrangement by tab 

order. For small mobile devices, the fields appear one above the next. 

After creating a new blank project, follow these steps: 

1. Consider the page layout and size. (Landscape provides more width than 

height.)  

2. Set the page size and orientation.  

3. Select Format > Page Setup from the menu.  

4. Choose the size on the size drop-down list, (or select custom and enter the 

width and height in pixels.)  

5. Select the Landscape option from the Orientation Group. 
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Supported Field Types, Commands and Functions 

 

See below for a list of supported and non-supported field types. The Web Survey 

System does not support all field types available in the Epi Info™ 7 Form Designer 

tool. 

Supported field types: 

• Label/Title 

• Text (Single line) 

• Multiline 

• Number 

• Date 

• Time (not Date/Time) 

• Checkbox 

• Yes/No 

• Option 

• Legal Values 

• Comment Legal 

• Codes 

• Group 

• Relate  

Although non-supported commands and functions don’t work when entering data 

into a web survey, they are still compatible with Check Code on survey versions 

running on the Epi Info™ 7 desktop. After downloading the web survey responses 

you can run these commands and functions as normal, using Epi Info™ 7 Enter 

Data.  

Supported Check Code Commands and Functions 

The Web Survey tool does not support all Check Code commands and functions 

available in Form Designer. See below for a list of supported and non-supported 

commands and functions. 
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Supported Commands: Non-Supported Commands: 

• Assign 

• Clear  

• Dialog  

o Simple Dialog only 

• Enable / Disable, 

• Go To 

• Hide / Unhide 

• Highlight / Unhighlight 

• If / Then / Else 

• Set-Required / Set-Not-Required 

• AutoSearch 

• Define 

• Dialog  

o Get Variable Dialog 

o List of Values Dialog 

• Execute 

• Geocode 

• Help 

• NewRecord 

• Quit 

 

Supported Functions: 
 

 

• ABS 

• Cos 

• Day 

• Days 

• FindText 

• Hour 

• Hours 

• LN 

• LOG 

• Minute 

• Minutes 

• Month 

• Months 

• Second 

• Seconds 

• Sin 

• StrLen 

• Substring 

• SystemDate 

• SystemTime 

• Tan 

• UpperCase 

• Year 

• Years 

— Sub, Trunc and Round not listed. 

Non-Supported Functions:  

• CurrentUser 

• DateDiff 

• Date 

• Environ 

• EpiWeek 

• Linebreak 

• NumToDate 

• NumToTime 

• PFROMZ 

• RecordCount 
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Non-Supported Functions:  

• Exists 

• Exp 

• FileDate 

• Format 

• Step 

• TxtToDate 

• TxtToNum 

• ZSCORE 

Non-supported commands and functions do not work when entering data into Web 

Survey. Non-supported commands are compatible with Check Code on the 

downloaded version of the survey. After downloading web survey responses, you can 

run non-supported commands and functions using Epi Info™ 7 Enter Data. For 

more information, review the Epi Info™ 7 — Guide to Enter Data. 

Differences in Check Code Performance 

In Check Code, the designer places commands within field blocks for actions such as 

Before, After, and Click. Check Code works differently in Web Survey than in Epi 

Info™ 7 Enter Data for drop-down list fields (e.g.: Yes/No, Legal Values, 

Comment Legal, and Codes). 

In Epi Info™ 7 Enter Data, Check Code executes when you leave the field, while 

tabbing or clicking on another field. In the Web Survey System, Check Code 

executes as soon as you select options from a drop-down list. Web Survey System 

will execute check code commands from drop-down lists like Enable/Disable, 

Hide/Unhide, Highlight/Unhighlight, and Set-Required/Set-Not-Required.  

Respondents must enter a choice in a required field. Web Survey and Epi Info™ 7 

Enter Data will not let you save or navigate to a new field, when required fields are 

blank. Required field notifications remind you that required fields must not be left 

blank. 
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Confirm Web Survey Compatibility  

You can ensure a web survey functions correctly by checking the tab order and 

entering test data. Try a practice sample analyses on some test data before 

publishing the form.  

For information regarding Tab Order, refer to the Form Designer section – How to: 

Use Tab Order. Logical tab order is critical when the respondent uses a phone or 

tablet. Tab Order determines the order in which fields display on a mobile device. 

Check Code validates data entry depending in part, on logical tab order on the 

desktop too.  

Review all field names to ensure each is concise and logical. Check various field 

names using the user-friendly Data Dictionary. For information regarding Data 

Dictionary, refer to the Form Designer section – How To: View a Data 

Dictionary. Once published, survey field names can’t be changed. 

Confirm tab order and field names and enter the sample test records. Click the 

Enter Data button from the Form Designer menu bar and preview the form in 

Enter Data. When entering test data, record any important changes prior to 

publishing the survey. Check the field validation and determine required fields. Be 

aware of valid ranges for numbers and date fields, or any other Check Codes that 

may apply.  

Try conducting anticipated analyses using your test data. Confirm the field names 

are clear and easy to use. If you intend to use a tool other than Epi Info™ 7 for 

analysis, export the test data in the desired format. Common corrections include 

resetting a long field name or changing and adding a field type. 

Note: Make corrections to field names and types before distribution.   

Next, practice publishing the survey as a test. Follow the Publish Form to Web 

instructions. Confirm that you can publish the form, navigate among the pages, 

enter more test data, and reconfirm working validations and Check Code behavior. 
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Ensure full functionality by downloading test data and performing a sample 

analysis. If you notice errors, make corrections, and repeat this step until the 

survey functions as desired.  

When testing is complete, remove all test data using the Delete Data Table 

function and publish the final version. For information regarding Delete Data 

Table, refer to the Form Designer section – How To: Delete an Existing Data 

Table Without Deleting the Form. 
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Initial Setup  

 

Collecting data and publishing a survey requires information generated by the Web 

Survey System or the system administrator. This information adds security and 

provides access to each survey. View some key terms found in Web Survey: 

• Endpoint Address – designates the location or URL of the application that 

hosts surveys. 

• Organization Key – provides survey designer access to publish the survey and 

import responses. 

• Survey Key – identifies the survey that corresponds to a security token for 

downloading data. 

• Security Token – grants access to survey data and prevents others with an 

organization key and survey ey from accessing the data. 

Before publishing a survey, designers must designate the endpoint address and 

binding protocol. 

Contact your Web Survey system administrator for: 

• An endpoint address  

• Use of Windows authentication (Yes or No) 

• A Binding Protocol (basic or wsHTTP) 

• An Organization Key  

From the Epi Info™ Form Designer menu, go to Tools > Options. Click on the Web 

Survey tab. The Web Survey Options dialog box appears. 
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      Endpoint Address field 

First, enter the Endpoint address, then enter your Windows authentication. 

Your Web Survey System administrator will provide you with a binding protocol.  

Note: An example of an endpoint address is: 

http://MySurveyManager.MyCompany.com/SurveyManagerService.svc 
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Publish Forms to the Web 

 

You can publish a survey that is compatible with the Web Survey System. Use 

Form Designer with your completed form. From the Form Designer menu, select 

File > Publish Form to Web. 

 

Publish Form to Web Survey 

If a form contains a non-supported field type, you’ll get an error message listing 

each invalid field.  

 

Unsupported Field Types error 
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Meet publishing requirements by deleting or changing the field type of non-

supported fields.  

 Warning! Before deleting a field, be aware that any collected data residing in the 

field will be permanently deleted.  

Caution: Backup all data prior to deleting a field.  

You can use the Change To option to change the field to a supported field type. 

Perform this action only if no data table is associated with the form. For 

information regarding Data Table deletion, refer to the Form Designer section – 

How To: Delete an Existing Data Table Without Deleting the Form. 

Note: Form data tables exist under two conditions: when users access forms with 

Enter Data or working with existing published forms, regardless of 

previously collected data. You can remove a data table. Go to: Tools > Delete 

Data Table. 

 

Change to Text Field Option 
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In the Publish Form to Web dialog box, fill out the required tabs listed below:  

• Introduction Page – provides information to the survey respondent prior to 

beginning the survey. It includes the survey title, and introduction message. 

The survey number and organization name are optional. 

• Exit Page – provides closing remarks to the survey respondent after they 

submit the survey. 

• Publish Options – specifies technical aspects of the web survey posting 

process. 

Use the dialog box navigation buttons: 

• Previous button — returns to the previous tab. 

• Next button — saves the information and proceeds to the next tab. 

• Close button — allows the user to exit the Publish Form to Web dialog box 

and return to the Form Designer window. 

• Publish button — attempts to publish the survey. Missing required 

information generates an error message. 

 

Publish Form to Web dialog box 

On the Introduction Page tab, click in the Give Your Survey a Title textbox to 

enter the survey title. This title will appear at the top of each page in the survey. 
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Enter your survey number or ID, organization name and department name. This 

information appears at the top of the introduction and exit pages. 

Note: Entering a survey title is required. Use the organization name for tracking.  

 Warning! Do not put the Organization Key into the Organization Name 

field on the Introduction Tab. The organization key allows you to post a survey to 

the web server. Always secure the organization key.  

The Welcome textbox provides respondents with a greeting, special instructions, or 

additional information about the survey. Click in the Welcome! textbox and enter a 

message.  

 

Intro Page with Welcome Screen 

 

Select the survey closing date from the Survey Closing Date drop-down menu 

located below the Welcome! textbox. This field only accepts a future calendar 

date.   

Note: The default setting is 10 days from the current date. 
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Survey Closing Date 

At 11:59:59.99 pm on the selected survey closing date, any attempt to access the 

survey will prompt the message below. 

 

Closed Survey Message 

Click Next to save this information and proceed to the Exit Page tab.  

Note: Edit the Introduction Page at any point prior to publishing the survey by 

clicking on the Introduction Page tab. 

 

Survey Exit Notification 
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The Exit Page displays closing remarks or additional instructions about the 

survey. Enter your comments in the textbox next to the green check mark. The 

example above displays, “Thank you for completing this survey,” and The 

Survey #. Organization and Department fields populate based on the information 

provided in the Introduction Page tab. Clicking on these fields will direct you back 

to the Introduction Page. Click Next to proceed to the Publish Options tab. 

 

Publish Options Tab 

Respondents can submit several responses per session by selecting the Many 

responses allowed button. The default setting is One response only, which 

closes the survey after the respondent submits one record.  

 Caution: Selecting One response only will not prevent a respondent accessing a 

survey link, more than once.  

Enter the Organization Key provided by the Web Survey System administrator. 

Note: For accuracy, copy and paste the Organization Key directly from an email 

attachment into the Organization Key field. The Organization Key must be a 

valid global unique identifier. A valid key enables the Publish Form button. 

An Organization Key looks like this: 3f6c6251-4af6-40f7-a440-cb2a9ca92e17. 
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Click Publish Form 

If you receive an error message in the Publish Status field, contact your Web 

Survey System administrator. You can view detailed information about the error by 

clicking the Log button. Typically, an error message occurs in the Publish Status 

field due to an invalid or missing endpoint address. 

The web URL, Survey Key and Security Token fields populate when the survey is 

published. Survey respondents can access a survey using the web URL. 

Click the Copy All to Clipboard button. Save this information to a familiar 

location so you can use it again.  

 Warning: The URL, survey key and security token are all required to access the 

survey and survey data. Do not lose your Security Token. Security 

Tokens are not recoverable. Keep the security token in a secure location. 

Do not share the security token with survey respondents. 
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Invite Respondents to Take the Survey 

 

Respondents can access a published web survey any time until the survey closing 

date. Respondents locate the survey using the web URL. Review the steps in the 

Publish Form to Web section. Designers can invite respondents by distributing the 

survey links through email, posting it to web pages, or sharing links elsewhere. 

Locate Surveys Using a Web URL  

Launch your web browser. Copy and paste the URL into the address bar at the top 

of your browser window. If the survey is not closed, the survey Welcome! page 

appears.  

 

Begin Survey Example 

 

 

 



Epi Info – Guide to Web Survey 

 

19 

 

Notice that a pass code is provided so that users can return to an incomplete survey 

later.  A DRAFT watermark appears to indicate the survey mode.  This mode 

allows testing for survey functionality and rendering.  

 

Click Begin Survey. The first page of the survey appears. 

 
Web Survey Form 

Enter your response to each survey question. Go to the next page of the survey by 

clicking on the navigation button on the top left corner of the screen. You can also 

click the Continue button at the bottom of the page. Clicking the Submit Survey 

button or the Finish Later button at the bottom of the page saves the completed 

form. Learn more about the Finish Later button in the section: Saving Survey 

Answers for Future Submission. 
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E. coli Web Survey Questionnaire 

 

Submitting Survey Responses 

After completing the last page of the survey, click Submit Survey.  

 

Submit Survey Window 

The Exit Page displays a thank you message.  
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Survey Exit Page 

If you selected Many responses allowed in the Publish Options tab, the Start 

Survey Again message will display. This offers respondents an opportunity to 

submit multiple responses.  

 

Start Survey Again message 
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Saving Survey Answers for Future Submission 

Respondents can save the survey and finish their responses later. Save the survey 

by clicking the Finish Later button located at the bottom of each page in the 

survey.  

 

Finish Survey Later Option 

A dialog box appears with a survey link and pass code. 

 

Pass Code Field 

Copy and save the survey link and pass code. The survey can’t be accessed without 

a survey link and pass code. Respondents can continue a survey by clicking Survey 

Link or Pass Code.  
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 Warning! Respondents must restart the survey if the pass code or survey link is lost. 

There is an option to email the survey link and pass code. Outgoing email addresses 

are not retained by the system.  

1. Enter a valid email address in the Email textbox. 

2. Re-enter the email address in the Confirm Email textbox. 

3. Click Send. The respondent will receive an emai with the survey link and 

pass code. 

4. To complete the survey, copy and paste the survey link into a web browser or 

click on the link in the email. 

5. Enter the pass code into the Pass Code textbox. Click Go. 

 

Enter Pass Code to View 

The displayed survey form contains all saved respondent entries. 
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Incomplete Survey Form 
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Importing Survey Data 

 

From the Epi Info™ main menu, select Enter Data. The Enter Data module 

opens. 

Steps: 

1. Open the project and form for the published web survey. 

2. From the File menu, select Import Data > From Web. 

 

                                                                    Import Data from Web 

3. Enter the Web Survey Key, Organization Key, and Security Token into 

the Import web form data dialog box (Refer to Publish Form to Web, Step 

13 for this information.)  
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Import Data Form 

4. Click Import.  

Caution: Ensure you’ve entered the endpoint address in the Web Survey dialog box, 

or you may see an error. 

5. After the import is complete, click Close. The responses in the survey are 

added to your Epi Info™ database. Add newly submitted responses by 

repeating the import process without generating duplicate records.  
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Data Screen after import 

                                                        

Collected data is ready for analysis. Refer to Visual Dashboard or Classic Analysis 

sections of the User’s Guide for more information about analysis features. 
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Changing Survey Mode from Draft to Final 

 

When the designer of the survey has completed all the changes of the survey and 

republished the survey in DRAFT mode to validate functionality and rendering of 

the form, the designer will need to change the mode of the survey from DRAFT 

mode to FINAL mode.  This process removes the DRAFT watermark on the survey 

and establishes the final version. To change the survey mode simply use the 

Change Mode option on the Form Designer menu bar and select Final. 

 

 

A confirmation message will be displayed to the user.  The generated URL is useful 

for any messaging for respondents. 
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DISCLAIMER 
The Centers for Disease Control and Prevention (CDC) provides the Epi Info™ software, translation 

databases, instructions, examples, sample projects with data, map files, and all other products 

available on this site (the products) on an “AS IS” BASIS, WITHOUT WARRANTIES OR 

CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any 

warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS 

FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of 

using or redistributing the products and assume any risks associated with your use or redistribution 

of the products.  In no event and under no legal theory, whether in tort (including negligence), 

contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent 

acts) or agreed to in writing, shall CDC or the Department of Health and Human Services (HHS) be 

liable to you for damages, including any direct, indirect, special, incidental, or consequential 

damages of any character arising from the use or inability to use the products (including but not 

limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and 

all other commercial damages or losses), even if CDC or HHS has been advised of the possibility of 

such damages. 

Epi Info™ is a trademark of the Centers for Disease Control and Prevention (CDC).  CDC does not 

endorse any commercial product or service, including any subjects of analysis or datasets.  Any 

references on this website, in materials downloaded from this website, or within the products to 

specific commercial products, processes, or services by service mark, trademark, manufacturer, or 

otherwise, does not constitute or imply their endorsement, recommendation, or favoring by CDC.
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