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4. Enter: Entering and Editing Data in 

Epi Info™ 

Introduction  
 

The Enter module allows users to enter data into forms constructed in Form Designer. 

Enter conducts the data entry process according to the settings and Check Code specified in 

Form Designer. Information entered into the form is stored in Microsoft Access or Microsoft 

SQL server data tables. 

Enter can be used to enter new data, modify existing data, or search for records. When data 

are entered into a form, the data table inside the project is populated. The Find function 

allows records to be located based on a series of matched variables. As data are entered, the 

cursor moves according to the tab order from field-to-field, page-to-page, and saves data 

when navigating to a new page. If you try to exit a page before data is saved, you will be 

prompted to save the data (Yes or No). 

Open a Project and Form 
 

To access the Enter program, click the Enter Data button on the Epi Info™ main menu or 

select Tools > Enter Data from the toolbar. In Form Designer, access the Enter module by 

clicking the Enter Data button in the toolbar. This button is a convenient method to switch 

between designing a form and entering data to test the form design. 

There are three options available to open a project and form. The following example uses 

the Food History form available in the EColi project. 

1. From the toolbar, select File > Open Form. 

 
Figure 4.1: Open Form 

 

2. Alternatively, click Open Form from the toolbar, 
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Figure 4.2: Open Form 

3. These two options will display the Open Form dialog box. 

 
Figure 4.3: Open Form dialog box 

4. Click the ellipses button next to the Current Project field to browse for a project. 

Select EColi from the folder. The project file path displays in the Current Project 

field and a list of available forms in that project appear in the Forms field. 

5. Select the desired form (FoodHistory) from the Forms field. 

6. Click OK. The project and form display with the first record in the project 

appearing on the canvas. 

For quick access to a project recently opened with the Enter module, use the Recent Forms 

option. 

1. From the toolbar, select File > Recent Forms.  
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Figure 4.4: Open Recent Form 

2. Select the path file containing the desired project and form. The project and form 

display with the first record in the project appearing on the canvas. 

 
Figure 4.5: Enter Workspace 
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Navigating the Enter Workspace 
 

There are five main areas in the Enter workspace: Pages, Linked Records, Canvas, Toolbar, 

and Status Bar. The figure below displays all five areas with information contained in the 

FoodHistory form of the EColi project. 

 
Figure 4.6: Enter Workspace 

Pages 

The Pages panel in the top left corner lists all pages associated with the current form. 

Users may navigate to different pages in the form by selecting the desired page in the 

Pages panel. 

Linked Records 

The Linked Records panel in the bottom left is used to conduct contact tracing. It 

contains information about which records have been exposed to or from the current record. 
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1. Exposed From – Displays additional records that the current record has been 

exposed or affected from. The Exposed From icons appear with the Case ID 

number of the record. Place the mouse over the record to preview the record 

information. 

 
Figure 4.7: Exposed From - Record Preview 

 Double-click on the record to jump to that record and view additional 

information 

2. Exposed To - Displays other records that the current record has been in contact  

with or possibly affected  since acquiring the illness. The Exposed To icons appear 

with the Case ID number of the record.  

 
Figure 4.8: Exposed To 

 Similar to the Exposed From tab, users can preview information or jump to 

the record by double-clicking the icon. 

3. Add Exposure – Identifies additional exposures (To and From) for the current 

record. To add an Exposure To, click Add Exposure in the Exposure To tab. To 

add an Exposure From, click Add Exposure in the Exposure From tab. 

 Select the form that the exposure record is contained. Click OK. 
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Figure 4.9: Add Exposure from Form 

 Find the desired exposure information with Find (information regarding the 

Find function is located in the Find Records section). Double click on search 

results to add the exposure to the record. 

 
Figure 4.10: Add Exposure from Record 

4. SNA graph – Social Network Analysis (SNA) displays the exposed to and from 

records graphically with the current record in red. 
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Figure 4.11: SNA Graph 

 The SNA graph directionally shows the flow of exposure at multiple levels. 

For example, the current record has two records that it has been exposed 

from; however, one of those records has been exposed from two more records. 

 The SNA graph also displays that the current record has been exposed to 

another record. This is consistent with the information contained in the 

Exposed From and Exposed To tabs. 

 The SNA graph can be saved as an image or printed using the buttons in the 

top left corner of the screen. 

Canvas 

The Canvas shows the current page in the form with all record information displayed. The 

canvas is where data entry and editing occurs. 

Toolbar 

The Toolbar at the top of the screen contains buttons to navigate through the records, 

create new records, open the Dashboard, open the mapping tool, save the current record, 

view records in a line list, and print. 

 Line List – allows users to view and search records using the Dashboard 

interface. Also, users can view the data in MS Excel and HTML formats.  For 

additional information, reference the Visual Dashboard section of the user 

guide. 
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Figure 4.12: Line List View 

 Print – allows the user to print the form and specify customized parameters. 

 
Figure 4.13: Print dialog box 

 To create a PDF version of the form using the print function select Preview. 

In the Print Preview window select Print and chose the appropriate PDF 

writer as the printer. 

Note: The ability to print to a PDF requires PDF writer software. 



Epi Info™ 7 User Guide – Chapter 4 - Enter: Entering and Editing Data 

 

4-9 

 

 
Figure 4.14: Create PDF 

 Navigation Buttons - Navigation is provided for using the New Record 

button and navigation buttons for, next ( ), previous ( ), first ( ), and 

last ( ) records. The user may also manually type the record ID number 

into the record list to jump to that record. When entering data into a child 

form, use the “Back” button to return  to the parent form. 

 Maps – Entering Maps from the Enter module allows for some additional 

functionality between Maps and the project data. The additional functionality 

allows the user to view case data in the Enter module from the Map window. 

The following example demonstrates how to create a case cluster map using 

the FoodHistory form data in the Ecoli project. For additional information 

regarding maps, reference the Maps section of the user guide. 

1. Click Maps from the toolbar. The Maps main window appears. 



Epi Info™ 7 User Guide – Chapter 4 - Enter: Entering and Editing Data 

 

4-10 

 

 
Figure 4.15: Main Map Window 

2. Select Add Data Layer > Case Cluster from the toolbar. 

 
Figure 4.16: Case Cluster 

3. In the external data dialog box, select No. 
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Figure 4.17: Data Source 

4. Select the field containing the Latitude coordinates (Latitude) from the Latitude 

drop-down list. 

5. Select the field containing the Longitude coordinates (Longitude) from the 

Longitude drop-down list. 

 
Figure 4.18: Latitude and Longitude Fields 

6. The case cluster map appears displaying each record’s location on the map.  
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Figure 4.19: Case Cluster Map 

7. To view the information associated with each record on the map, double-click on a 

single red dot. The record appears in the Enter data window. 

Note: Zoom in on the record of interest to separate the case clusters into single 

dots. 



Epi Info™ 7 User Guide – Chapter 4 - Enter: Entering and Editing Data 

 

4-13 

 

 
Figure 4.20: Case Record 

Status Bar 

The Status Bar at the bottom of the screen displays selected information about the field 

that the cursor is currently located. The status bar can be hidden by deselecting View > 

Status Bar in the toolbar. 

 
Figure 4.21: Status Bar 
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Check Code Options 

The Enter module allows the user to modify the Check Code features when entering data. 

Both Check Code options are available under Tools in the toolbar and are enabled by 

default. 

 
Figure 4.22: Check Code Options 

 Enable Check Code Executions – Unchecking this option will disable all check 

code when entering data into the form 

 Enable Check Code Error Suppression -  Unchecking this option will not 

display error messages in check code 

 

Import Data 

There are multiple options available to import data from external sources into the Enter 

module. These options are available under File > Import Data in the toolbar. 

 
Figure 4.23: Import Data 

 From form – This feature requires a Epi Info project file (.prj) and data (.mdb if 

data tables formed in Microsoft Access).  
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o Browse for the Epi Info project file by clicking the ellipses next to the Project 

containing the data to import field. Select the .prj file 

o Select the Form from the Form data to import drop-down list. 

 
Figure 4.24: Import Data from Form 

o Select the Import Type from the Type of import drop-down list. 

 Update and append records – Records in the destination form 

containing the same GlobalRecordId values as the source form will be 

updated (overwritten) if there is new information. However, values in the 

destination table will never be overwritten with a null or missing value. 

All other records will be appended (added) to the end of the table. 

 Update records only – Records in the destination form containing the 

same GlobalRecordId values as the source form will be updated 

(overwritten) if there is new information. However, values in the 

destination table will never be overwritten with a null or missing value.  

All other records will be ignored. 

 Append records only – All records in the source form will be appended 

(added) to the end of the table. No records will be updated (overwritten).  

o Click Import. Import Complete will appear at the bottom of the dialog box 

upon successful completion of the import. 
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o Click Close. The data is imported into the Enter module. 

 From mobile device – for information regarding this feature, reference the 

Companion for Android section of this user guide. 

 From web – for information regarding this feature, reference the Web Survey 

section of this user guide. 

 From data package – for information regarding this feature, reference the Data 

Packager section of this user guide. 

Enter Data in a Form 
 

New Record 

1. With a form and project open, select New Record from the toolbar or File > New 

Record. A blank record is added to the end of the record list and displays in the 

canvas. Place the cursor in the data entry field. 

2. Enter data into each field. Use the Tab or Enter key to move to the next field. 

Moving from one field to another will execute Check Code. 

 As records are navigated, data are saved automatically. After completing the 

last field on a page, the cursor automatically jumps to the next page in the 

sequence. 

 Field properties that were defined in Form Designer, (e.g., Read Only, Required 

Range) are enforced during data entry.  

 Drop-down lists and code tables created in Form Designer are enforced.  

 Multiline Fields automatically scroll when filled with text to hold up to 1 

gigabyte of information. 

 Plain text fields automatically scroll when filled with text to hold up to 255 

characters per field. 

Edit Record 

1. Navigate to the desired record using the navigation tools in the toolbar. 

2. Place the cursor in the desired data entry field. 

3. Enter data into each field that needs to be updated. Use the Tab or Enter key to 

move to the next field. Moving from one field to another will execute Check Code. 

 

Delete Record 

1. Navigate to the desired record using the navigation tools in the toolbar. 

2. Select the Delete button in the toolbar, or select Edit > Mark as Deleted. 
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3. The record is grayed out and removed from any analysis performed in Visual 

Dashboard and Classical Analysis. 

Undelete Record 

1. Navigate to the desired deleted record using the navigation tools in the toolbar. 

2. Select the Undelete button in the toolbar, or select Edit > Undelete. 

3. The record is enabled and will be available for analysis in Visual Dashboard and 

Classical Analysis. 

 

Insert an Image in a Record 

1. Click the Image Field. The Select the Picture File dialog box opens. 

2. Select an image file. 

3. Click Open. The selected image appears in the field.  

 
Figure 4.25: Insert Image 

Save a Page or Record 
 

The Enter module saves data automatically as the user moves from page-to-page. Data are 

also saved when navigating to another record. You can move out of a record by tabbing out 

of the last field of the last page or clicking New Record from the toolbar to open a new 

record. Records can also be saved manually. 
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There are three ways to save the current record manually: 

1. Click Save from the toolbar. 

2. Select File > Save. 

3. Press Ctrl+S from the keyboard. 

Find Records 
 

Find can search for a record matching any field value or combination of field values. If a 

form has more than 255 fields and more than one associated data table, only the first data 

table will be searched with the find feature. As a result, only the fields in the first data 

table will populate in the search results. 

 

Find Records Matching a Specified Criteria 

The example below demonstrates how to find records in the FoodHistory from in the 

EColi project. 

1. From the toolbar, select the Find icon or Edit > Find. The Find Records window 

opens. 

 

Figure 4.26: Find Record 

2. The Select/Unselect Search Fields list displays on the left side of the Finds 

Records window with all fields contained in the form. Click on a field name to select 

one or more fields. The selected search fields will turn blue and populate the gray 

area to the right of the list.  

3. To unselect a field, click on the selected field highlighted in blue. The field will no 

longer be highlighted and is removed from the search criteria.  
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Figure 4.27: Find Records Window 

4. Enter the search criteria for each field and click Search. Note that certain fields 

require specific formatting for the search criteria. If more than one field is selected, 

the search will display records that match all search criteria. This is considered an 

“AND” search.  

 Yes/No fields can only be searched with the parameters (+), (-) or (.). The 

parentheses are required.  

 Checkbox can only be searched with the parameters (+) or (-). The 

parentheses are required.  

 Date fields can only be searched with the date format MM/DD/YYYY. 

 Comment Legal can only be searched with the code (i.e. F- Female, search for 

F) 

 Option boxes do not store the option labels and therefore must be searched 

according to the integer that corresponds to each option. In an option box, the 

first option available corresponds to 0, the second option corresponds to 1, etc. 

Enter the corresponding value into the search criteria. 
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 Number fields will only accept values but do not require a decimal point if the 

field format specifies a decimal value. 

 Click Reset to begin a new search. Note that more than one field can be 

searched at a time. 

 Click Back or the close (X) button to return to the Enter workspace. 

5. Open a record by double-clicking the arrow on the chosen row. The record displays 

in the Enter Data workspace. 

 
Figure 4.28: Find Records Results 

Additional Search Features 

1. Embedded text items in multiline and text fields can be found by searching for 

*word* where "word" is the text string being sought. This type of search is called a 

Wild Card search. In a Wild Card search, the asterisk represents any letter or string 

of letters (i.e., a search for DIAGNOSES *heart* would identify all records for a 

large text field called DIAGNOSES which contained the word "heart)." 

2. Dates and numeric fields can be searched using less than or greater than values 

(<>). 
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3. Only “OR” can be used to search for matches based on more than one criteria in the 

same field (i.e. searching last names, Smith OR Doe will return records containing 

both Smith or Doe. The search field must contain “OR” to perform the desired 

search. Search criteria cannot be separated by a comma. 

4. Searches are not case sensitive and are designed to be more inclusive than exclusive.  

 

Printing Forms 

 

Users can print a blank copy of the form or a copy of the form with data if needed.  In order 

to print the form, please complete the following steps: 

1. Open your Epi Info 7 project and form in the Enter Data module. 

2. Click on the PRINT option.  The following window will be displayed: 

 

 

Figure 4.29: Print dialog window 

 

a. To print a copy of the form without including the data that has been entered, 

just click the PRINT button 

b. To print a copy of the form including the data that has been entered for the 

current record, click on the CURRENT RECORD radio button, and the click 

the PRINT button.  This will print the form with the data for the current 

record. 

c. To print a copy of the form including the data that has been entered for a 

range of records, click on the RECORD RANGE radio button, and then 

specify the record number for the records that you want to print the data.  

When done, click the PRINT button.  This will print the form with the data 

for the records specified. 
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d. To print a copy of the form including the data for all records, click on the ALL 

RECORDS radio button, and the click the PRINT button.  This will print the 

form with the data for all records in the database. 

 

3. To print an electronic copy of the form without any data,  click on the PREVIEW 

button. 

 

Figure 4.30: Print Preview dialog window 

 

4. Click on the printer icon button. 
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Figure 4.31: Select Printer dialog window 

 

 

5. Select PDF writer or any other option that allows the creation of an electronic copy 

of a document. 
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